NEED HELP with Intek 60 engine

Discussion in 'Mechanic and Repair' started by 2001john, Feb 14, 2005.

  1. 2001john

    2001john LawnSite Member
    Posts: 23

    Hi There,
    Have this intek 60 engine that won't increase or decrease RPM it starts easy run good at 3000 RPM but won't change from that.

    Have changed governor spring and linkage arm
    Have ajusted governor arm
    Tried another carby
    All with no change still does the same thing any ideas out there whats going on here.

    Regards John
     
  2. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    Sounds like your throttle cable is broke if you can't speed it up slow it down.
     
  3. rockytopp

    rockytopp LawnSite Member
    Posts: 120

    You might unhook the linkage at the carb. and manualy operate the throttlel. This will help eliminate the problem. if the gov. is adjusted correctly , then the problem is in the cable or carb. is the carburator linkage itself free and not binding?. should be a simple cure.
     
  4. 2001john

    2001john LawnSite Member
    Posts: 23

    Thanks I'll try that !
     
  5. 2001john

    2001john LawnSite Member
    Posts: 23

    Have looked at the carb when operate manaualy can increase & decrease the RPM of the engine . The cable is in good condition.
    The carb shaft has play up & down but not binding
    any ideas what to try .

    John
     
  6. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    Are you sure the cable is not broke? Operate the throttle and see if the other end of the cable is moving. Is the cable hooked up to your throttle lever?
     
  7. 2001john

    2001john LawnSite Member
    Posts: 23

    yes it work at both ends . That was the first thing I had looked at .

    John
     
  8. 2001john

    2001john LawnSite Member
    Posts: 23

    Hi rockytopp,
    Thanks for the advice here . I come across another linkage mount for this engine change that over and she was right . But looking at the two mounts look the same but it must of had a small bend in it enough to throw the govenor out.
     

Share This Page