Never in my life have a had so much trouble with hand helds

Discussion in 'Mechanic and Repair' started by exmarkking, Jan 9, 2014.

  1. Tuttled

    Tuttled LawnSite Member
    Posts: 151

    Check your spark plug gap as well!
  2. exmarkking

    exmarkking LawnSite Bronze Member
    Posts: 1,012

    Already checked the gaps! They are new plugs in them already since I've replaced everything trying to find the original problem. I definitely think it's a fuel/carb issue so now I've solved the fuel problem let's see if the carbs act right.
    Posted via Mobile Device
  3. exmarkking

    exmarkking LawnSite Bronze Member
    Posts: 1,012

    This is the equipment list I'm switching over to pure fuel:
    Exmark navigator
    Exmark lazer z
    Exmark 21" push mower
    Exmark turf tracer
    Redmax trimmers
    Redmax edgers
    Redmax blowers
    Husky chain saw
    Honda powered pressure washer
    Honda powered greens mower
    Posted via Mobile Device
  4. lawnboy dan

    lawnboy dan LawnSite Gold Member
    Posts: 3,712

    replace the bad carbs with new ones. sometimes rebuilding them just dosnt work. stop using eth. gas.

    ACME LANDSCAPE LawnSite Member
    Posts: 21

    well just a different view of what i see happening .. with the epa tightening up on regulations they have forced the companies to use carbs that are extremely on the lean side to help cut down on polution...
    mix that with a fuel that contains inconsistent mixtures of ethanol you get even a leaner burn.. ethanol will lean out the air fuel mixture in itself. not by much but a little ...
    so mix the 2 lean applications and you will get lean running equipment which will run erradic at wot ..

Share This Page