1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

New FT 20/52

Discussion in 'Hustler Turf Equip (Archived)' started by RSkinner, Jul 25, 2006.

  1. RSkinner

    RSkinner LawnSite Member
    Posts: 6

    I noticed the vent tube on my Left Hydro Motor does not have a clamp and comes off easy. The right one has a clamp. I think this is partly to do with the Brake Rod/Control Rod is directly over the vent on the left side and causes interference issues while the right side does not suffer from this.

    Is there a fix for this in the works or do I just need to hose clamp it and not worry about it. A replacment 45 degree plastic fitting in the top of that pump would fix this rather than having it point straight up into the rod.
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    E-mail me your serial #, I need to get this to our quality control department.
    Have you called your dealer? he can take care of this for you, or you can put a clamp on it.
  3. RSkinner

    RSkinner LawnSite Member
    Posts: 6

    I have no problem installing a hose clamp but I wanted to let you know in order to avoid some warranty work or have some poor sole loose an IZT pump. Since is appears to be a repear problem by looking over other post I thought I would chime in. I'll email my serial number for your reference.
  4. cranesrule

    cranesrule LawnSite Member
    Posts: 104

    Be very careful and get a clamp on that thing asap. I had mine come off, and I unknowingly ran my machine without it until I found it laying in the yard. Use a screw clamp instead of a spring clamp. I also agree that a 45 degree fitting would be a good fix. Just putting a wear sleeve on it and allowing it to be pushed off to the side is not a very good design on an otherwise fantastic machine.


Share This Page