New guy, Z-Force 50 stops when taking off the brake

Discussion in 'Mechanic and Repair' started by PlainsmanND, Oct 9, 2009.

  1. PlainsmanND

    PlainsmanND LawnSite Member
    Posts: 6

    Hello, I have a Z-Force 50 about 3 years old 275 hours. Its well maintained.

    Today I went to get the last mow of the season in and when I take off the brake she stops. I suspect the seat switch, I unplugged and jumpered it but it acted the same way. Is there a diode in the switch where that isn’t a valid test? Is there a way to disable that for certain so I can determine if it’s the switch?

    I am familiar with the mower and am pretty mechanical.

    Procedurally, open the sticks, brake on, engine fires. Take in sticks and engine stops or take off brake engine stops.

    Looks like a good technical group here so I expect someone’s seen this.

    Mower serial 2G145Z00070

    Thanks!
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Put a multimeter set on ohm's scale across the seat switch connectors (while un-plugged of course) then make a fist and push on the center of the seat, If the switch doesn't show a open and closed circuit while being pushed in and let out replace the switch.....
     
  3. PlainsmanND

    PlainsmanND LawnSite Member
    Posts: 6

    Cool, so odds sound good its the seat switch. If thats the case where's the place to get one?

    Thanks
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

Share This Page