New Hustler Mini Z Owner with Questions

Discussion in 'Hustler Turf Equip (Archived)' started by fthomasr, Jun 28, 2010.

  1. fthomasr

    fthomasr LawnSite Member
    Posts: 13

    I just bought a 2007 Mini Z 42" Kawa 19hp 56hrs (I spoke with you about it PJ, via email)

    Cut for the first time tonight and wow! Leaves a very clean even cut. Quite impressed.

    Where should the throttle be set when engaging the blades? The manual just says 'not full throttle.' Half throttle? Seems to LUG the engine down for a second pretty hard at anything below 3/4 throttle.

    How hard should the throttle lever be to move? Mine is quite stiff and takes a good bit of force to slide (choke also.)

    When both levers are forward it pulls to one side. I've checked the parts manual and there is nothing I could find about adjusting for that, only parking. Is there an adjustment for it?

    The hydros whine quite a bit, however I've never driven a ZTR before so I don't know what's normal. The previous owner had never so much as lifted the seat. The hydro oil was low in the overflow tank (but not empty) so I brought it up to the fill line. I've read on here that going with Amsoil 20w50 and new filters eliminates the whine.
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    Your going to want to engage your pto at half to 3/4 throttle, keep your other hand on the choke, in some cases when the engine is colder you need to choke it a little bit when engaging the deck, once the deck is engage and the engine is running without the choke take it to full throttle and start cutting.
    Your throttle and choke cables are a bit stiff on that model, it is due to the cable routing in the tight spaces on your mower, this is normal.
    Here is the link to your parts manual > http://www.hustlerturf.com/images/product_manuals/107652_0307.pdf
    Go to page 9-28 and you will find your adjustments for the control linkage.
    The noise your hearing from your hydros is normal to a extent, if it is overly loud at full throttle then I would talk to your local dealer.

    Pj
     
  3. fthomasr

    fthomasr LawnSite Member
    Posts: 13

    There's only 8 chapters! No 9-28.
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

  5. fthomasr

    fthomasr LawnSite Member
    Posts: 13

     
  6. ronmowers

    ronmowers LawnSite Member
    Posts: 23

    If we can be of assistance for parts and accessories please feel free to email us and we will assist you in any way we can. Thank you
     
  7. fthomasr

    fthomasr LawnSite Member
    Posts: 13

    Are you a Hustler dealer?
     
  8. ronmowers

    ronmowers LawnSite Member
    Posts: 23

    No we are not a Hustler dealer but can get many parts and accessories to you quickly.
     
  9. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    Your air filters and engine oil filter need to come from Kawasaki, your engine model and spec are as follows:
    Kawasaki 19 HP FH580V-S36-R
    You can order those from any Kawasaki engine dealer.

    Your hydro filters are Hustler part # 600976

    Mulch kit...
    Kit, Mulch 36/42" FasTrak SD, w/o blade 107654 MSRP $95.00
    Wavy mulching blade is Hustler part # 794214
    Gator blade is Hustler part # 794230

    Blow out kit, there is not one available for your deck.

    Kit, Hitch, FasTrak SD 36/42 only 107696 $42
    Kit, Steering Lever Extension, FasTrak 333724 $79
    Kit (2 forks), FasTrak Super Duty / Hustler Z4 600213 $212
     
  10. fthomasr

    fthomasr LawnSite Member
    Posts: 13

    Ordered the Hustler wavy blades, mulching kit, paint, and hydro filters. Also bought Amsoil 20w50. Drained the hydro tranny and threw on blades/mulching kit. Began the purging procedure. Noticed something that is bothering me.

    When I place the two hydros bypass into lock position the right side wheel still is engaged and spins when purging. The right wheel does not spin until I disable the bypass. Went through procedure two times. Bypass on and then off. Then went for a ride. Everything seems fine...still whines the same but I guess it's normal.

    The used oil that came out looked very clean (50 hours).

    What do you think about the bypass not working? I can clearly see the lever turning the shaft all the way.
     

Share This Page