New MINI Z 23/52 I'm getting covered in debri!!!

Discussion in 'Hustler Turf Equip (Archived)' started by AUWarEagle, Sep 11, 2007.

  1. AUWarEagle

    AUWarEagle LawnSite Member
    Posts: 32

    I've got a MINI Z 23/52 with a mulching kit....Problem is while mulching i'm getting covered with dust and clippings from the front left side of the deck..Is this a common issue for this mower?? What can be done to stop it?? The customer want's the yard mulched, but so much blow out does make for clippings left in the yard not to mention the amount on me!!!!!!! I bought this mower thinking that it was one of the top of the line products, but with this experience it has left me second guessing my decision....Please Help!!!!!
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    What blades are you using?
    Are you using a full mulch kit? as in closure plate and 2 baffles?
     
  3. AUWarEagle

    AUWarEagle LawnSite Member
    Posts: 32

    PJ...I'm using the Hustler Full Mulch kit 2 baffels and closure plate w/ gator mulching blades.
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    Ok.
    How much are you taking off in a single pass?
    Has your dealer looked at the problem?
    Deck pitch may play a role in this also.
    Gator or wavy mulching blades work best, sometimes one better than the other. I would double check the deck pitch and if that doesn't help with the situation, try taking off less in a single pass.
    Last resort try a set of wavy mulching blades.
     
  5. AUWarEagle

    AUWarEagle LawnSite Member
    Posts: 32

    The one yard inparticular is zoysia grass and I cut it once a week...I'm cutting at 3 1/4 and would say i'm only taking off a 1" to 1" 1/2 on my passes.
     
  6. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    I would still recommend my above recommendation's, in particular the wavy blades.
     
  7. AUWarEagle

    AUWarEagle LawnSite Member
    Posts: 32

    PJ I tried the wavy mulching blades and it did not make a difference.....Mower has to got the shop as now I have a different problem...The left side pump motor wil not work for about the first 10 minutes the mower is running....then it will start working. I guess while it's at the shop i will have them check the deck pitch. I'm just very frustrated..as mower only has 21 hours on it.
     
  8. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    Hmmm... thats weird...
    Let me know what they find with both issues...
     
  9. AUWarEagle

    AUWarEagle LawnSite Member
    Posts: 32

    Pump motor problem was the Hydro oil filter was loose....sucking air...deck pitch is supposed to be right...but still getting alot of blow out on front left side.
     
  10. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    About the only other reason your getting blow out would be cutting conditions at this point, I think your part of the country has been dry, hasnt it?
    If all of the above has been checked and it still does it, its all thats left....
     

Share This Page