New Redmax HBZ2601 Problems

Discussion in 'Lawn Mowing' started by Landscape89, Jan 12, 2008.

  1. Landscape89

    Landscape89 LawnSite Member
    Posts: 237

    I got this Redmax blower yesterday, filled it and it ran for about 2 minutes before chugging and then stalling. I thought I flooded it so I dried the spark plug off and made numerous other attempts to start it up. NO Success. Took it out today to retry, no success. What I did notice though is that when Im priming the engine, instead of the gas going up into the carberator it appears as if its going right back down to the tank. Also, instead of the primer bulb "Popping out" like it should, it just remains pushed in and doesnt pop back out. Has anyone had any type of problem like this before?? :confused:

    Thanks for any help,
    SH
     
  2. 44DCNF

    44DCNF LawnSite Bronze Member
    Posts: 1,462

    When priming, excess fuel after prime is reached does get routed back to the tank so that part is normal. It sounds like maybe the pick up line in the tank or between the tank and carb may be kinked. Does there seem to be a vacuum in the tank when you remove the cap after this happens?
     
  3. Landscape89

    Landscape89 LawnSite Member
    Posts: 237

     
  4. grass_cuttin_fool

    grass_cuttin_fool LawnSite Gold Member
    Posts: 3,504

    I know that my post doesnt offer any help...didnt the dealer fuel it and run it some 1st before he sent you home with it?


    wayne
     
  5. Landscape89

    Landscape89 LawnSite Member
    Posts: 237


    It ran fine with a little gas in it for a few minutes. Then last night had all these problems :mad:
     
  6. grass_cuttin_fool

    grass_cuttin_fool LawnSite Gold Member
    Posts: 3,504

    sounds like the vent in t he cap is malfunctioned if you here a vacum when opening the gas cap. I would leave it loose so it can vent and see if it still does it or if that solves the problem

    wayne
     
  7. Landscape89

    Landscape89 LawnSite Member
    Posts: 237


    Its very confusing. When the primer doesnt pop out, or when the little fuel that is primed appears going back into the gas tank. However, everytime I have tried to start it... the Spark Plug is wet. I mean it has the sound like it's ready to fire up though! :hammerhead:
     
  8. J&R Landscaping

    J&R Landscaping LawnSite Fanatic
    Posts: 5,096

    I'd put just a tiny bit of fuel in it and take the fuel cap off. Prime it 2 or 3 times, full choke and hold full throttle. Pull the cord and get it running. It should pop start and die with in 3-5 pulls if not less. Put the choke to half or so, hold full throttle and get it going again. You might have to play with the choke a bit. If your still having an issue, check the in tank fuel line and make sure the filter is attached and the line don't have any cuts or an "alligator" surface to it. If you don't want to do this, take it back to the dealer and let him mess with it.
     
  9. nate121080

    nate121080 LawnSite Member
    from va
    Posts: 66

    if your primer bulb isnt popping back out IT HAS A KINK IN THE LINE! Trust me thats the only thing that will cause it. I had one drive me fits one time cause of that. I pulled the hose out of the tank and thats where it had the kink. Reinserted the way it should be and no problems since.
     

Share This Page