1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

no brake lights.....Ford f350

Discussion in 'Mechanic and Repair' started by mdb landscaping, Nov 24, 2004.

  1. mdb landscaping

    mdb landscaping LawnSite Silver Member
    Posts: 2,205

    well, today was going good till i was about ready to leave our shop and somebody said hey, you got no brake lights.(this on a 2003 f-350) went next door and talked to our electrical guy who ironically has a shop we rent to him. he looked at it, determined first i had a burned out third brake light. fixed that, and then he said it looks like i may have a bad signal flasher which if not working would give me no brake lights. i have all signals and parking lights, but no brake lights. i went down to the ford dealer, picked up a new signal flasher and asked them where its located. they said under the dash, left side under the auxillary fuse panel. well ive looked high and low and cant find the damn flasher. has anybody out there had to change one? or could point me in the right direction. i may just go grab another truck at work to drive around, but id like to fix it sooner instead of monday. got any ideas where it is?
  2. CCWKen

    CCWKen LawnSite Member
    Posts: 113

    It should be at the bottom of the fuse block. Remove the cover as if to access the fuses; it should be at the bottom. Blue, I think.
  3. mdb landscaping

    mdb landscaping LawnSite Silver Member
    Posts: 2,205

    yes the signal relay i bought is blue. ill check in the morning and try to locate it. thanks for the help.
  4. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,100

    If you have all your signals I would check the brake light switch located on the brake pedal arm on most vehicles.
  5. mdb landscaping

    mdb landscaping LawnSite Silver Member
    Posts: 2,205

    ya im gonna check that too. i had several people on another forum tell me it may be a bad brake pedal switch. thanks for your help.
  6. earthwerks unlimited

    earthwerks unlimited LawnSite Member
    Posts: 43

    I had the same problem on my '83 F-600 dump. Replaced the brake switch with new and now it's gone bad.

Share This Page