odd trimmer problem

Discussion in 'Mechanic and Repair' started by MikeKle, Jun 27, 2008.

  1. MikeKle

    MikeKle LawnSite Platinum Member
    Posts: 4,253

    I just cleaned my Echo SRM-210 trimmer and now it is running like it is bogged down and doesnt seem to be able to reach a high RPM. I removed the muffler and scraped all the buildup off the outside and took a small wire brush to the inside and got it looking pretty good,used carb and choke cleaner on all external surfaces, including the carb(looks brand new) and the heat sinks on the engine, cleaned out the entire air filter housing and put a new filter in, and now it runs like crap! go figure, I thought it would run like a champ.Anybody else have this happen to them?
     
  2. MOW PRO LAWN SERVICE

    MOW PRO LAWN SERVICE LawnSite Bronze Member
    Posts: 1,566

    Pull the screen out of the muffler?
     
  3. MikeKle

    MikeKle LawnSite Platinum Member
    Posts: 4,253

    I did pull the screen out and did not put it back,it was caked up pretty bad, Ive always heard those screens are very restrictive..
     
  4. Two Seasons

    Two Seasons LawnSite Senior Member
    Posts: 791

    Partial choke is what it sounds like to me.
     
  5. Breezmeister

    Breezmeister LawnSite Bronze Member
    Male, from South Jersey
    Posts: 1,571

    Inside of what ? Muffler or exhaust port ?
     
  6. Partsangel

    Partsangel LawnSite Member
    Posts: 80

    Why did you clean it ? was it running poorly :confused:

    :rolleyes:

    How was it running before you cleaned it ?

    Curious Mike
     
  7. topsites

    topsites LawnSite Fanatic
    Posts: 21,653

    I know this doesn't help with your current problem, but this is
    why guys like me always say "if it ain't broke don't fix it" :p
    Then again I did learn this one the hard way myself.

    Good luck man, it will be all right.

    hahaha
     
  8. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,307

    That chock cleaner stuff could have damaged the diaphragms inthe carb if you put a lot into it? Try a new fuel filter and plug and then adjust the carb. Is it not starting, or running bad at idle, or running bad at high rpm. The low carb adjustment will help starting and idle, and the high carb adjustment of high rpm.
     
  9. MikeKle

    MikeKle LawnSite Platinum Member
    Posts: 4,253

    It is actually running great now? That first day after I cleaned it the thing ran terrible, but then the following day it seemed to get it out of its system and started running good. I cleaned the muffler and the exhaust port out because from prior experience I think it is better to have the exhaust system as clear and unrestricted as possible.Thanks for the suggestions though.
     

Share This Page