Oh oh...coolant leak on new Scag TT.....

Discussion in 'Mechanic and Repair' started by Bilrus61, Jun 15, 2014.

  1. Bilrus61

    Bilrus61 LawnSite Member
    Posts: 51

    Ok noticed that the new Scag TT Kubota 25 HP used some coolant and I topped it off the other day. Thought it might just be getting its level in the radiator and didn't worry much. Went out today and there is a 8 inch green puddle under where the hose from the lower right of the engine joins the lower right side of the radiator. I wiggled the clamp and it feels tight. Ok the mower is 3 weeks old and had 15 hours on it. This is the third issue I've had with it. I've never had any trouble with my many other Kubota engines.

    I've read that the plastic radiator opening/pipe sometimes cracks if the hose is tightend too much and there is no fix but a new 700 buck radiator. So I guess I'll cross my fingers and call the dealer monday and hope it gets fixed under warrenty. So a missing air cleaner clamp........air intake hose getting a hole in it from vibrating against the sharp corner of the bolt on the water temp sensor and now a radiator leak. Also it was low on hydro fluid and the dealer ran it out of fuel. It also moves when the handles are folded out if the engine is running.:dizzy: I guess I should be thankful the handles are both at the same level!
     
  2. bverboy

    bverboy LawnSite Member
    Posts: 35

    aint it under warrentty???????
     
  3. Bilrus61

    Bilrus61 LawnSite Member
    Posts: 51

    Yeah its only 3 weeks old so it should get fixed without any expense.....but my 40 year history on warrenties has been very poor. I've not touched it or tried to fix the leak just put it in the garage so the pets woudln't lick up any of the coolant. Going to call tomorrow and see what the dealer wants me to do.
     
  4. bverboy

    bverboy LawnSite Member
    Posts: 35

    scag is supposed to be a good machine. American made and assembled here... Wisconsin.....hope they do ya right.....
     

Share This Page