overheating scag

Discussion in 'Lawn Mowing' started by turfguy, Aug 24, 2003.

  1. turfguy

    turfguy LawnSite Member
    Posts: 141

    My new turf tiger with a kawi liquid cooled engine just started to use coolant. Last friday I needed to add about two cups to the overflow tank on the side. After a long day of cutting it was dry again. engine seems to run hotter than normal. oil is clear, no drips on the trailer or the shop floor. I pulled both plugs and they look clean, no strange smells.....realy has me and my dealer stumped. with only 150 hours I hope I didnt get a lemon. It is at the dealer right now getting a preasure test. for the second time......any thoughts I am getting a little bit perturbed.
     
  2. J.Gordon

    J.Gordon LawnSite Senior Member
    Posts: 675

    I would check your radiator cap. I have seen a lot that wouldn’t seal right out of the box.
    I hope that’s your problem! Good luck:)

    Jeff
     
  3. Ditto, that would be my guess also, seen it many times on cars and trucks.
     
  4. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    Was your overflow completely empty? I had a Tiger that would empty out the overflow as you described every couple days. There would always be coolent at the top of the Rad., but the tank would be down to a few drops. Dealer said that was fine as long as the Rad. was full. I think it is pretty goofy, but it did not seem to hurt anything.

    Jay
     
  5. J&R

    J&R LawnSite Senior Member
    Posts: 835

    I just hope you have better luck with your Scag than i have had with my Turf Tiger the shop has it more than i do.
     
  6. J.Gordon

    J.Gordon LawnSite Senior Member
    Posts: 675

    Did you ever find the problem?
     

Share This Page