Permagreen Mag - Honda engine 'pulses'

Discussion in 'Mechanic and Repair' started by DA Quality Lawn & YS, May 5, 2013.

  1. DA Quality Lawn & YS

    DA Quality Lawn & YS LawnSite Fanatic
    Posts: 8,867

    Hi Guys,

    I am not horribly concerned but thought I would throw this out there.

    I have a 2008 PG Magnum with the Honda GX200 engine. Ever since I bought this machine 2nd hand, when I pull open the throttle above 3000 RPM (to the max 3450) the engine 'pulses' or in other words, the throttle seems to pulse back and forth instead of holding a steady level. I can reach down by the engine and hold the cable steady and this will take the pulse away....but when I let go it oscillates back and forth from the carb. What might be going on here? Bad plug? Carb need clean?
     
  2. djagusch

    djagusch LawnSite Platinum Member
    from MN
    Posts: 4,203

    If it goes away with holding the throttle lever on the engine I would look at the cable cable adjustment. Its not holding the lever tight. It also could be the throttle stop on the carb lever.
    Posted via Mobile Device
     
  3. dadoorsron

    dadoorsron LawnSite Member
    Posts: 21

    Sounds like a broken Idle spring. It's the spring that is attached to the carburetor, I can't remember when Permagreen went to the gas tank on the engine instead of on the side. If you have the plastic tank on the side you will have an easy time changing it. If the tank is on the top of the engine. take the air filter off and loosen the carburetor so it slides out a few inches. This will make life a lot easier. Other then that, the idle screw can be turned down to much.
     

Share This Page