permagreen magnum

Discussion in 'Fertilizer Application' started by wardslandscaping10, Apr 14, 2012.

  1. wardslandscaping10

    wardslandscaping10 LawnSite Member
    Posts: 4

    i have a permagreen magnum and the impeller wont spin properly and the liquid pump wont spray any ideas?
     
  2. Greenery

    Greenery LawnSite Senior Member
    Posts: 512

    Start with the basics, check the belt, make sure all pulleys spin freely with the belt off, belt tension, etc.
    Posted via Mobile Device
     
  3. wardslandscaping10

    wardslandscaping10 LawnSite Member
    Posts: 4

    the pulleys spin free but the tension pully for the impeller does not spin and the bolt will not come off the pulley is that normal?
     
  4. DA Quality Lawn & YS

    DA Quality Lawn & YS LawnSite Fanatic
    Posts: 8,869

    As far as the pump, make sure it is getting primed. I know if I run my Mag clear out of mix and refill, the pump WILL NOT prime itself well and I have to turn the cleanout valve on briefly until I get a good flow THEN the pump will prime with liquid to the nozzles.
     
  5. Greenery

    Greenery LawnSite Senior Member
    Posts: 512

    If you're talking about the one hanging on a arm from up above than yes that should spin freely. All of them should spin freely with the belts off with exception of the one on the engine.

    If that tension pulley is froze up you're belt probably got smoked. The bolt holding that pulley to the arm should be stainless, so corrosion shouldn't be a problem.
    Posted via Mobile Device
     
  6. wardslandscaping10

    wardslandscaping10 LawnSite Member
    Posts: 4

    yeah the bolt that goes through that pully is froze inside the pully. when i took the pully off the bolt stayed in the pully. and when i tighten the pully it does not move it stays in place.
     
  7. wardslandscaping10

    wardslandscaping10 LawnSite Member
    Posts: 4

    i tried to pressurize the system with a hose and it started to spray very weak and then stoped working again but i am going to try again after i replace the belt and tension pully. thanks
     

Share This Page