permagreen

Discussion in 'Pesticide & Herbicide Application' started by RigglePLC, Jun 21, 2009.

  1. RigglePLC

    RigglePLC LawnSite Fanatic
    Posts: 11,785

    I have an old Permagreen Ultra. Last week it started making a chirping squeak sound at times. Only when moving. I cannot locate the source of the sound, but possibly it is from the front wheels or near there. So...I found the rubber oil filler plug on top of the tranny--and added about 1/3 bottle of gear oil.
    Anybody know how much to add or how to check this? Source of squeaks? It is running OK--but--5 dollars for gear oil is a lot easier than a new tranny.
     
  2. turf hokie

    turf hokie LawnSite Silver Member
    Posts: 2,743

    Mine started doing that a while ago. We found the roller bearing on the rear tires were shot.
     
  3. RigglePLC

    RigglePLC LawnSite Fanatic
    Posts: 11,785

    Lifted (with difficulty) the rear wheels spin--no squeak. So i suspected the front transaxle bearings.
    No more squeak afer I added the 90 wt oil. Hope that cures it. And for good.
     
  4. Runner

    Runner LawnSite Fanatic
    Posts: 13,496

    Take into consideration, that they may not squeak when the machine is lifted and pressure is off of them. Much like a wheel bearing in a car.
     
  5. RigglePLC

    RigglePLC LawnSite Fanatic
    Posts: 11,785

    Permagreen Ultra. Spotted oil leaking out onto the carrier. Left side axle seal or something near there is leaking. I added 90 wt gear oil. It works Ok for the time being.
     
  6. turf hokie

    turf hokie LawnSite Silver Member
    Posts: 2,743

    Keep an eye on it if it is a seal or close the end (wheel) of the transaxle. I had one leaking and did not get it to the mechanic quickly enough and now hope that we did not ruin the transaxle.
     

Share This Page