Phazer 34 problem

Discussion in 'eXmark' started by Turfman999, Sep 8, 2007.

  1. Turfman999

    Turfman999 LawnSite Member
    Posts: 72

    What can be done to keep my main deck belt from popping off all the time?
    It will come off several times a day, especially when engaged at a low engine RPM. When it first started happening, I replaced the belt thinking maybe it was stretched out. That made no difference at all. It seems to me that the main spring on the tension pulley is too easy to stretch and put back on by hand. The worst part is that the belt always goes below the pulley, thus requiring the pulley to be removed in order to get the belt back on track. Can you give me any advise??? This thing is still under warranty but I can't afford to be without it for days.

    Thank You
     
  2. eXmark

    eXmark Manufacturer / Sponsor
    Posts: 4,258

    Turfman999,

    There is an update kit available that will fix your problem. The kit includes a new idler pulley, idler arm, and belt. Your dealer should be able to install this update kit in less than 1 hour, and is covered under your warranty. Let me know if you need anything else!

    Casey
     
  3. captbob

    captbob LawnSite Member
    Posts: 86

    There is also A bushing upgrade for the parking brake I used to have to float mine sometimes to start the engine but the little brass bushing fixed er up right quick and in a hurry. Ant I have never lost a belt after the fix the new pully belt system is very HD Good ol Ex Mark spent some bucks on this upgrade make sure you ask for your old belt back it will work with the upgrade....... Capt Bob
     

Share This Page