Phazer keeps shutting down

Discussion in 'Mechanic and Repair' started by goodgreen, Sep 14, 2006.

  1. goodgreen

    goodgreen LawnSite Senior Member
    Posts: 364

    I love my new ExMark Phazer. Most of my yards range from small to medium so it works great for those gated back yards. But I've had problems with it not starting twice now. How often does the battery need charging? I just charged it up this past weekend and it would not start last night. Luckily I was done with my work, but it was a nightmare trying to push it up onto the trailer manually. Got help from a nearby neighbor. Handles and brake seem to be a little touchy as far as needing to be in the correct position to start. But I couldn't do a thing with them.
     
  2. Jim@MilkyWay

    Jim@MilkyWay LawnSite Senior Member
    Posts: 472

    You should never need to charge a healthy battery in a machine with a healthy charge system.
    If you suspect the switch positions causing no start condition, that is the place to start. If you are not sure of battery, check the voltage at battery while someone turns the key to start position.
    How old is the mower? Has the battery been out of the machine recently? If so, are you sure the cables were properly attached to battery when reinstalled?
     
  3. newz7151

    newz7151 LawnSite Silver Member
    from Tejas
    Posts: 2,419

    We are no longer an eXmark dealer, but I remember there being a service bulletin to install some kind of bushing on the brake lever to help it contact the switch.. maybe that could be causing your problem? Or is your battery totally discharged when you test it?
     

Share This Page