Plow fell off...

Discussion in '<a href=http://www.plowsite.com target=_blank ?>Sn' started by SlimJim Z71, Jan 6, 2001.

  1. SlimJim Z71

    SlimJim Z71 LawnSite Senior Member
    Posts: 691

    Not mine... thank god.

    The guy I was plowing with at work has a Western 7.5ft. Pro Plow. I'm not sure what he hit, or if it's just from years of abuse, but the mount on the truck broke. He had to drag it down to the shop in reverse and go buy a new mount. Never seen that before.

    Also, salesman out on a testdrive in a BMW X5. Wanted to show the customers it's off-road capability. Ditched it! Luckily there was a Chevy around (Mine) to go pull it's $60,000 butt out!

    Interesting day.

    -Tim
     
  2. Rooster

    Rooster LawnSite Senior Member
    Posts: 460

    SlimJim,
    Are you sure you didn't get that big snowblower and try to gobble that truck up :) but stopped when the blade came off!

    ;)

    Just kidding, How have you been?
     
  3. SlimJim Z71

    SlimJim Z71 LawnSite Senior Member
    Posts: 691

    Snowblower... I WISH! I'm doin okay now I think...
     
  4. FIREMAN

    FIREMAN LawnSite Senior Member
    from n.j.
    Posts: 318

    OH...I HATE IT WHEN THAT HAPPENS.....LOL
     
  5. Guido

    Guido LawnSite Silver Member
    Posts: 2,085

    Makes you want to add some stuff to your emergency kit, or make one if you don't already have one!!

    Keep some cargo straps and a digging bar with you, never know when you'll need them!!

     
  6. jrblawncare

    jrblawncare LawnSite Senior Member
    Posts: 445

    Now thats a bad day....Just got the emergeny repair kit for my western....I did not see a spare truck mount in the box.
     
  7. SlimJim Z71

    SlimJim Z71 LawnSite Senior Member
    Posts: 691

    I guess it did the same thing on Friday when he was plowing, but he was able to weld it. After yesterday, I think it's time to bury that old mount...

    -Tim
     
  8. Dusty

    Dusty LawnSite Member
    Posts: 97

    Used to have a problem with the bolts comming loose on the Fisher mount. Had it welded solid and no more problems.
     
  9. 75

    75 LawnSite Senior Member
    Posts: 992

    Also not mine...thank god! A customer brought this one into the welding shop where I work a couple of weeks back. Fairly new Western straight blade (7.5') with the pivot bolt hole torn out of the moldboard! Had to have hooked something going in reverse, we didn't see it happen, we just got to fix it. (Cut out a section of the bottom leg of the angle, fab up a replacement plate with the proper hole, vee everything out for a full penetration weld and sew it all back up.) Anyone seen or experienced anything like this before? First time I'd ever seen something like that!


    1975 GMC C-35
     
  10. finnegan

    finnegan LawnSite Member
    Posts: 109

    75, same thing happened to us on or 8ft. proplow,same exact thing,i really beefed it up,won't ever happen <html><strong> again!!!

    [Edited by finnegan on 02-05-2001 at 08:43 PM]
     

Share This Page