Possible pump problem??

Discussion in 'Water Features' started by DanaMac, Dec 22, 2007.

  1. DanaMac

    DanaMac LawnSite Fanatic
    Posts: 13,156

    I don't do much with ponds, but I replaced a pump in March for a client. he called again two days ago and said he thinks it is going out again. He said in March that he had gotten a slight "oil" slick in the water and then the pump had seized up. He says he has the same "oil" slick again.

    The pump is an Aquascape 3000. The original was an older vertical pump. New one is horizontal. Company I bought the pump from said they do not have oil in them anymore so it should not be from the pump. Any other thoughts? Is it the pump? Dead fish somewhere causing oil?
  2. STL Ponds and Waterfalls

    STL Ponds and Waterfalls LawnSite Bronze Member
    Posts: 1,177

    I just replaced an ADI 3000 pump that I installed in May. I was winterizing the pond and noticed the pump wasn't running. I checked it and it was starting to seiz up and it had an oil slick.. Last year I replaced an ADI 3K pump that was 4 years old. So, I'm wondering if the quality of the pumps are suffering since they have a 2 year warranty now. I'm going to try the Tsrumi pumps and see how long they last.
  3. ICT Bill

    ICT Bill LawnSite Platinum Member
    Posts: 4,115

    Oil slick, I would have to see it first hand to diagnose it properly

    Here is part of a description "Aquascapes DesignsÂ’ horizontal pumps utilize an industrial grade double mechanical seal in a non-toxic mineral oil cooled chamber. The outboard seal faces are long life silicone carbide material, which is a premium seal of the more commonly used, less expensive carbon ceramic seals found in most sump pumps."

    Mineral oil - Oil slick 2+2= , Yeah it probably bit the dust or is biting the dust.

    Try Aquatic Eco Systems for products, great company and great service

    For external pumps I prefer WLim or sequence
  4. n2h20

    n2h20 LawnSite Senior Member
    Posts: 503

    ICT, have you ever used Performance Pro Pumps?
    I used to use the Sequence until A rep called me one day from Performance. I have installed maybe 20 of their pumps to 15 of Sequence and never had a problem with any of them except a broken lid. Sequence i have had to replace 3 due to a bad seal of some sort.
    Have you had to replace any Sequence pumps?
    Do you buy your pumps from a dealer or direct?
  5. cindyb

    cindyb LawnSite Senior Member
    from KY
    Posts: 354

    Aquascape pumps have had some problems. Is it under the 1 year warranty?

    Dead fish won't cos oil.

Share This Page