Poulan Pro Trimmer

Discussion in 'Mechanic and Repair' started by EddieCarr, Jun 19, 2007.

  1. EddieCarr

    EddieCarr LawnSite Member
    Posts: 4

    I have a Poulan Pro PPB100 trimmer that has a detachable head that's two years old. Ran great until recently, and now won't accelerate. Changed plug and fuel pickup, no help. If i detach the head, it runs great and will accelerate normally. Any help appreciated!
     
  2. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    Is the head hard to spin after you took it off?
     
  3. EddieCarr

    EddieCarr LawnSite Member
    Posts: 4

    No the head spins freely and the drive cable is spinning freely in the tube.
     
  4. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    Remove your spark arrester and replace the plug
     
  5. EddieCarr

    EddieCarr LawnSite Member
    Posts: 4

    First thing i did was replace the plug and fuel pickup....didn't make a difference.
     
  6. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    What about the spark arrester?
     
  7. EddieCarr

    EddieCarr LawnSite Member
    Posts: 4

    Not familiar with the spark arrester. Need help with that.

    Also, from what I've read, carbon build up on the muffler is a common problem. Your thoughts on that? Don't really see how to get to the muffler through the cover.
     
  8. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    You should be able to look inside the muffler outlet and see a small mesh screen. Pull it out if it's there. If not remove the cover and muffler and check the exhaust ports for restrictions.
     

Share This Page