Power Loss

Discussion in 'Mechanic and Repair' started by barlaam1, Apr 12, 2010.

  1. barlaam1

    barlaam1 LawnSite Member
    Posts: 22

    I have a 99 Encore z48 with something like 2500 hours. I think it has a 18 horse brigs. The problem I'm having is when the motor is cold and I engage the blades it boggs down and isn't worth a darn. If I let it warm up you can hear the engine find a higher full throttle. then the mower works great for like 5 min. then I'll be mowing along and it boggs down back to where it was when it was cold. even with the blades off it can't get back into that sweet spot. what should I look at first? I havn't checked the plugs and the air filter could probably use replacing. I'm just worried this might be a head gasket. I can't mow with it when it is acting like this. Thanks for everything guys.
  2. topsites

    topsites LawnSite Fanatic
    Posts: 21,653

    Plugs and air filter.

    Don't just look at them, replace. gap .030
  3. barlaam1

    barlaam1 LawnSite Member
    Posts: 22

    will do that first thing today. Thanks topsite
  4. ALC-GregH

    ALC-GregH LawnSite Fanatic
    from PA
    Posts: 7,053

    and if he looks at them and they are good? You're saying to just throw money at it anyway?

    Check the fuel filter to see if there's dirt in it. It's most likely a in line filter.

    If you're not sure what to do, consider dropping it off at a dealer.
  5. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,245

    2500 hrs on a Briggs ? Thats almost as believable as our president having a US birth cert.

    In any case, you didnt say which 18 hp engine you had. I'm assuming you have an opposed twin. Sounds like trash in the fuel bowl. Remove the top of the carb and clean everything.
  6. barlaam1

    barlaam1 LawnSite Member
    Posts: 22

    Well I got bad news. My mechanic said that it needs a valve job and the head gaskets replaced. what a great way to start off the season.

Share This Page