power washer not priming

Discussion in 'Mechanic and Repair' started by bligh61, Jul 27, 2007.

  1. bligh61

    bligh61 LawnSite Member
    Posts: 240

    I have a karcher power washer, engine runs fine but doesnt always build up pressure. sometimes it runs fine then the pressure just cuts out. any ideas?
     
  2. dutch1

    dutch1 LawnSite Silver Member
    from Jayhawk
    Posts: 2,231

    I have an old Karcher HD10BX with a 13HP Honda horizontal, direct drive 2500 psi pump that developed a similar problem. After replacing all the check valves the problem was solved. You can go to Karcher's website with a model number to find a parts diagram and determine whether a teardown/repair is feasible.

    Dutch
     
  3. fly-4-fun

    fly-4-fun LawnSite Member
    Posts: 0

    Sounds like the unloader valve needs attention.
     
  4. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,100

    First off the input pressure must be at a minimal of 40 PSI with a flow rate of at least the rated flow of the pressure washer. Pressure washer are what is called a "displacement pump". The input does not draw suction. I have seen people even try to use a water barrel with a pressure washer. And another thing the nozzle of the pressure washer is MATCHED to the pump. The wrong size nozzle will cause problems. A nozzle that works on one may not work on another one.
    Check you water flow to see you have enough to run the unit. If so then check the input screen. Well water will cut the life of a pressure washer short due the all the deposits found in well water.

    The unloader will start sticking from water deposits
     

Share This Page