1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Problem with Echo "star blade" brush cutter.

Discussion in 'Mechanic and Repair' started by uncle timmy, Jan 19, 2012.

  1. uncle timmy

    uncle timmy LawnSite Member
    Posts: 5

    I have used Echo Weed eaters for years. I am very happy with them. Recently after many years of use one of mine locked up and I purchased an new one. When changing from the 'string' to the 'blade'.. I noticed that when i run it , the reversed threaded nut will tighten SO TIGHT that it prevents my blade from spinning. I have to wonder why? i HAVE NEVER had a problem with my old Echo running the 'star blade" ( 3 point Echo brush blade). Any help with be appreciated.
    Thanks,
    Uncle Timmy.*trucewhiteflag*
     
  2. GlynnC

    GlynnC LawnSite Senior Member
    Posts: 770

    I think you are missing a part--perhaps it came off when you removed the string head. It's called a plate adaptor, it fits over the shaft, and is the last thing that goes on before screwing on the string head. This plate should keep your brush blade from tightening down so tight that it locks up the blade. It's part number 61031347731--at least for an Echo SRM230. You should be able to do a parts lookup for your model.
     
  3. Ridin' Green

    Ridin' Green LawnSite Fanatic
    Male, from Michigan
    Posts: 12,847

    ...or use your old one maybe.
     
  4. orangemower

    orangemower LawnSite Silver Member
    from pa
    Posts: 2,773

    You're missing the adapter. Like Green said, you can use the old adapter off the broken trimmer. They are interchangeable.
     
  5. uncle timmy

    uncle timmy LawnSite Member
    Posts: 5

    That is just the thing that has me confused. I bought this brush cutter for my old one. ( it was a 2400) I bought a 225 from a Home Depot ( convenient at the time).. and it seems very comparable, the string heads fit interchangeabley.. but when I put the (entire set up) on for the star blade , it tightens down so tight it stops my blade. I do have all the parts. With out the proper adapter the star would have nothing to hold it in center. I just wonder if there is a slight difference in the depth of the 'lug' ( addapter) ?? :usflag:
     
  6. BigFish

    BigFish LawnSite Silver Member
    Posts: 2,904

    LOOK to see if the blade is contacting the housing somewhere. You might have to put a plain ol flatwasher under the blade adapter to space it up/out a tad.
     
  7. uncle timmy

    uncle timmy LawnSite Member
    Posts: 5

    Good idea.. I thought of a washer, but not under the housing.. You are a genius.!! lol :drinkup: I'll give it a try .
     
  8. BigFish

    BigFish LawnSite Silver Member
    Posts: 2,904

    True...........I AM a genius!........... Or is that " a legend in my own mind "?
     
  9. uncle timmy

    uncle timmy LawnSite Member
    Posts: 5

    I'll let you know if it works.. makes perfect sense to me. Believe it or not, I am a millwright .. but I never considered putting a washer UNDER the adapter.. .. Enjoy that beer I bought you!! HAHAHHA ( I am soooo darn ready to get to work!!, stir crazy)
     
  10. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,240

    Yes....Fish....you probably are a genius. .....you're the one getting the Free beer.
    Legend? ......When they start writing books about you..........
    Posted via Mobile Device
     

Share This Page