1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Problem with Hydro Pump

Discussion in 'Wright Manufacturing, Inc. (Archived)' started by grassman534, May 1, 2011.

  1. grassman534

    grassman534 LawnSite Member
    Posts: 4

    The other day when i was mowing with my sentar and the drive belt went out. I knew what it was right away bc it had happen once before. So I opened the bypass valves and coasted it on the trailer. My mechanic fixed it right away and had no problem driving it back on the trailer. But as soon as i got back to the job I couldn't get it to back off the trailer. The left wheel operates perfectly but the right wheel has no power, (basically just enough to spin the tire when you have the back wheels jacked up off the ground) I checked the reservoir right away and noticed it was low. After filling it to the proper level I bled the lines as instructed in the owners manual but it did not seem to help at all. Is there any other way to bleed the system?

    Also, there are no visible leaks on any of the lines. And strangely after the mower sits for an hour or so it drives and works fine for about 30 seconds and then the right wheel loses power.
     
  2. grassman534

    grassman534 LawnSite Member
    Posts: 4

    any suggestions wright?
     
  3. WrightCommercial

    WrightCommercial Inactive
    Posts: 526

    Sorry Grassman, I missed this post somehow. Let me forward onto our service team and someone will respond asap!

    Thanks!
     
  4. WrightCommercial

    WrightCommercial Inactive
    Posts: 526

    grassman534,

    Are the pumps making any noise? I would suspect that the bypass valve might be allowing air into the system. You mention that the oil was low, has the machine been looked over for a leak in the hydro system? How old is the mower and how many hours?

    Best Regards
    Wright Mfg.
     
  5. grassman534

    grassman534 LawnSite Member
    Posts: 4

    Wright Mfg,

    No the pumps are not making noise. I have been looking for leaks but there does not seem to be any that I can see. The mower has 1100 hrs on it. I tightened the bypass valves with a wrench to make sure they were tight. Do they ever go bad and leak? I just dropped it off at the mechanic and they are going to test it. Just wanted to see if it could be something simple before I spend the money on a new pump.
     
  6. WrightCommercial

    WrightCommercial Inactive
    Posts: 526

    grassman534,

    Sometimes the valves can strip the casting on the pump but would usually leak or let air in causing cavitation. Hopefully they will flow test the pump which is really the only way to test them.

    Best Regards
    Wright Mfg.
     

Share This Page