1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Problem with my Echo power head

Discussion in 'Lawn Mowing' started by GreenGiant94, Mar 9, 2012.

  1. GreenGiant94

    GreenGiant94 LawnSite Senior Member
    Posts: 271

    Hey everyone. Im having a problem with my echo power head that i use mainly for hedge trimming. I noticed when i was using it yesterday that it started to smell and i noticed smoke was coming out of the muffler from it being hot. This didn't seem like burnt oil smoke, it was smoke from being hot. Id say it took about 30 min of use before it started this. The unit is pretty new and has been well cared for. Has anyone had any trouble like this? What do you think it is? I have never had anything like this take place in past years. I use the same gas mix for my other equip and there working fine. Thanks for any ideas.
  2. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,200

    Those convertor get very very hot. And maybe you are running a little rich on carb adjustment or mix. First thing is to look for any leaking fuel mix around the cyclinder the breather and carb.
  3. GreenGiant94

    GreenGiant94 LawnSite Senior Member
    Posts: 271

    Ok thanks. Ill be sure to check it for leaks.
  4. TheChiefsLawnCare

    TheChiefsLawnCare LawnSite Senior Member
    Posts: 961

    i hate when people do it to me so imma do it to you. shoulda bought a stihl lol.

Share This Page