Problems Mulching with Exmark 26" Metro

Discussion in 'Lawn Mowing' started by joed, Jul 28, 2005.

  1. joed

    joed LawnSite Bronze Member
    Posts: 1,168

    After a long wait, I finally got the mulching kit for my exmark metro 26". Despite the lack of success with this unit, I gave it one more try only to find more disappointment. I tried to mulch a few lawns at 2.5" with the unit. With our heat wave, the grass is barely growing. Unfortunately, too much grass is escaping under the deck and not getting mulched. As a result, you get clippings being left on the surface of the grass...thus requiring another pass. Has anyone else with this unit experienced the same thing? Is there another fix for it?
     
  2. joed

    joed LawnSite Bronze Member
    Posts: 1,168

    Any replies guys?
     
  3. Maxham_farms

    Maxham_farms LawnSite Member
    Posts: 7

    I have one of those mowers...It is broken right now...my dealer can't get the blade belt. That mower is always broken..If I were you, I would leave that thing at the shop and get a 21" snapper or other throwaway.
     
  4. True Harbor

    True Harbor LawnSite Member
    Posts: 114

    I picked up a 26' snapper and have had no problems with it. It turns easily because of the swivel wheels in the front.
     
  5. dishboy

    dishboy LawnSite Platinum Member
    from zone 6
    Posts: 4,318

    it will work just fine if you add some parts, take away some parts and do about thirty hours of testing to figure out what ones help and what doesn't!
     
  6. Howard Roark

    Howard Roark LawnSite Senior Member
    from Texas
    Posts: 805

    Is this not a residential mower?
     
  7. joed

    joed LawnSite Bronze Member
    Posts: 1,168

    Dishboy,

    What parts need to be added?
     
  8. soutwestlawns

    soutwestlawns LawnSite Member
    Posts: 8

    my dealer raised up the rpm on the engine ,it realy did help
     
  9. Howard Roark

    Howard Roark LawnSite Senior Member
    from Texas
    Posts: 805


    I did the same thing with mine and determined the machine is STILL a total piece of crap. NEVER EXMARK AGAIN is my new motto.
     

Share This Page