problems with a western plow

Discussion in '<a href=http://www.plowsite.com target=_blank ?>Sn' started by dtm, Jan 21, 2001.

  1. dtm

    dtm LawnSite Member
    Posts: 10

    I have a 1999 western pro plow. My proplem happend right before our last storm. When I hooked up the plow and hit the raise button the plow angled right and stayed right. No matter what button I hit on the remote the plow still only goes right. Has any one ever had this proplem or knows what may cause this. Thanks for your help.
     
  2. Mike Nelson

    Mike Nelson LawnSite Senior Member
    Posts: 416

    dtm,
    It sounds like a faulty ground,might try some electric spray and replug.Just my 2 cents
     
  3. PINEISLAND1

    PINEISLAND1 LawnSite Member
    from WEST MI
    Posts: 201

    dtm-

    I have the same plow, same year. Every time there is a problem like that it has been electrical connections. As was said above, re-do all connections, hit em good with dielectric grease, then go from there. It may be that simple.
     
  4. wyldman

    wyldman LawnSite Member
    Posts: 182

    Had one last week,same problem.Was a tiny metal shaving stuck in one of the valves.Took everything apart,blew it all out and reassembled and it works great.
     
  5. DanG

    DanG LawnSite Member
    Posts: 234

    If you go to the western web site they have trouble shooting charts there. http://www.westernplows.com

    I had the same problem with mine and like the others said check your connections first.

    The trouble charts helped me out.

    Dan
     

Share This Page