1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Pulled the trigger/ New Exmark 30 for me...

Discussion in 'Lawn Mowing Equipment' started by rbljack, Mar 5, 2013.

  1. Utah Lawn Care

    Utah Lawn Care LawnSite Bronze Member
    Posts: 1,304

    Mine broke too after about 50 hours. The dealership replaced it for free.
     
  2. NEW CITY LAWN CARE LLC

    NEW CITY LAWN CARE LLC LawnSite Bronze Member
    Posts: 1,268

  3. rbljack

    rbljack LawnSite Senior Member
    from Texas
    Posts: 702

    Mine broke a drive cable, and it broke right up by the handle assembly.
     
  4. SSantor

    SSantor LawnSite Member
    Posts: 201

    My cable broke near the handle assembly also. It would be nice to hear from an emark rep. about the cable issue. They are good to work with and have been honest with me about different things. To exmark: What are you doing to fix the cable design? We still love the machines, just want all the bugs worked out. They seemed to work out the tranny problem, we need to fix the cable situation now. I still would recommend this machine, just need to adjust a few things.
     
  5. sildoc

    sildoc LawnSite Silver Member
    Posts: 2,925

    Seems to be a cable problem all the way around. Had the same problem with my toro turfmaster. Other than that I can't complain.
    I would recommend a better trans regardless that has more power or traction for hilly conditions or even just going up the ramp on the trailer.
     
  6. SSantor

    SSantor LawnSite Member
    Posts: 201

    I agree. I would like to see alittle more pull going up hills or even on small slopes or trailer ramps. I also find that you have to adjust the side cables more then you should. We do really like the machines, just can't wait till they take care of some of these items.
     
  7. SSantor

    SSantor LawnSite Member
    Posts: 201

    I talked with exmark today about the cables breaking. They informed me that it was a ball at the end of the cable that needed to be redesigned that was causing the cables to break. They have fixed that problem I've been told. They said all the new cables are ready to go. If your cable breaks it's under warranty and will be replaced by this new design. I appreciate the honest words from exmark. If I'am missing any thing exmark rep. please chime in. I just want to get factual information out to others.That is what is really good about this site, getting facts and other companies opinions on lawn mowing issues.
     
  8. lawnsaspire

    lawnsaspire LawnSite Bronze Member
    Posts: 1,511

    i wonder what else will need to be "redesigned"on these machines.
     
  9. NEW CITY LAWN CARE LLC

    NEW CITY LAWN CARE LLC LawnSite Bronze Member
    Posts: 1,268

  10. rbljack

    rbljack LawnSite Senior Member
    from Texas
    Posts: 702

    Yep, when my drive cable broke, they replaced it under warranty at no charge, but I didn't realize there was a new design. Not sure if I have the new version, or an original though??
     

Share This Page