1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice


Discussion in 'Hustler Turf Equip (Archived)' started by bigcheese2007, Jul 15, 2013.

  1. bigcheese2007

    bigcheese2007 LawnSite Member
    Posts: 5

    I have Super Z with the xr7 deck and the 31 hp motor on it and I was wondering if someone could give me some info on rebuilding one of the hydro pumps on it or direct me to a thread that already has this info. I'm pretty sure its the pump that's going out. The mower doesn't like to be loaded on the trailer at all and struggles going up hill some. Could it be the drive motor on it? Thanks!
  2. hustlermidwest

    hustlermidwest LawnSite Senior Member
    Posts: 636

    Have you done any testing on the drive system? Flow test? PSI? Hate to see you invest time and money on a guess.
    I'm on vacation so I'll let the field chime in on this.

    Brian O
  3. bigcheese2007

    bigcheese2007 LawnSite Member
    Posts: 5

    No sir I haven't. It just shutters whenever you turn it and does it real bad whenever you are loading it on a trailer.
  4. Sharpcut 1

    Sharpcut 1 LawnSite Senior Member
    Posts: 450

    I will almost guarantee you're gonna need to do both. The wheel motor inner and outer shaft start stripping, causing the chattering your talking about. Metal shavings from shaft get in pump, both will eventually fail. Most of the time the wheel motor starts first, and then the pump. Just repairing or replacing pump isn't going to do anything if pressure is being lost in wheel motor.

Share This Page