Question for Walker owners?

Discussion in 'Lawn Mowing' started by rjones14, May 31, 2008.

  1. rjones14

    rjones14 LawnSite Member
    from Alabama
    Posts: 17

    I have an 01' GHS with a 48" deck. I am having a problem with clippings building up in the motor area of the mower, mainly towards the front under the seat. It has gotton so bad that after each cut I have to open everything up and blow it out. Has anyone elese had this problem?
     
  2. Precision Lawns

    Precision Lawns LawnSite Senior Member
    Posts: 283

    Where is the grass coming from? Is there a good connection between the blower chute and the hopper? I used to run an MD, only ever had that problem when the hopper didn't close all the way after dumping. Hope that helps.
     
  3. DavisLawn

    DavisLawn LawnSite Member
    Posts: 141

    make sure theres not a hole in the blower cover... mine did the same thing and that was the problem.... we welded a patch on it ... problem solved
     
  4. Dean of Green

    Dean of Green LawnSite Senior Member
    Posts: 254

    Check your blower housing for a hole. Sounds like you might have one. I had a small hole that shot grass and leaves all over the same area you are speaking of.
     
  5. Dean of Green

    Dean of Green LawnSite Senior Member
    Posts: 254

    I guess I am a slow typer.
     
  6. KS_Grasscutter

    KS_Grasscutter LawnSite Gold Member
    Posts: 3,335

    Yup, I'd check the blower housing. Also check the chute between the deck and the blower.
     
  7. rjones14

    rjones14 LawnSite Member
    from Alabama
    Posts: 17

    Thanks guys.
     
  8. Itsgottobegreen

    Itsgottobegreen LawnSite Silver Member
    Posts: 2,177

    Also you can wear a hole in the pickup tube from the deck. It will do the same thing.
     

Share This Page