question...

Discussion in 'Wright Manufacturing, Inc. (Archived)' started by jsf343, Apr 25, 2013.

  1. jsf343

    jsf343 LawnSite Bronze Member
    Posts: 1,767

    I have a 36" wright sentar that is having issues cutting out and eventually dying when the bade is either engaged or disengaged and this is when it has been running and is warmed up. almost acts like it is running too rich at the time that it does this but it doesn't necessarily smell rich or smoke, My thought was maybe the blade engagement switch itself?

    anybody experience this before? or any thoughts?
     
  2. WrightCommercial

    WrightCommercial Inactive
    Posts: 526

    jsf343,

    Not knowing the year of your 36" Sentar Sport check if you have the one piece harness, if so look for the blade delay module (square plug in with two mounting holes molded into it) and make sure it is free of debris. Also check for any loose connections and pushed out connections. It is unusual that it is cutting out when disengaging as it sounds like the pressence system is being tripped but that should not happen when disengaging the blades.

    Best Regards
    Wright Mfg.
     
  3. jsf343

    jsf343 LawnSite Bronze Member
    Posts: 1,767

    hmmmm.... I want to say it is either a 2008 or 2009 off the top of my head. I will check those items and get back to you. It seems to cut out more when turning the blades back on rather than off. either way it is always related to the blade switch.

    Thanks for the help on this.
     

Share This Page