Rebuilt my E-47 this weekend !!!

Discussion in '<a href= target=_blank ?>Sn' started by UNCLE BOB, Feb 13, 2001.


    UNCLE BOB LawnSite Member
    Posts: 99

    I rebuilt my unit this sat.,Plow was dropping down-stright.MANY of you gent's sugested I goto the "A" valve first.And if that did'nt do it then I may need a new base.The "A" valve was right on,the o ring on it was in pieces. I also ordered a new base,filters and a master seal kit.I did what I can only describe as a total rebuild, new base,filters and seals,every thing inspected and cleaned. I got all my part's from Angelos at a fraction of local cost's. I have'nt remounted it yet but I'll let you all know how it's working. Thank's for the help and advice from everyone whom responded to my questions! you were all right on the money. Thank's agian UNCLE BOB Pic's of my rig : coming soon to a monitor near you
  2. Deere John

    Deere John LawnSite Senior Member
    Posts: 327

    Good luck with your project Bob - hope it works well for you. I have to admit, you have more patience than I do for tinkering with the heart of your plow.
  3. plowjockey

    plowjockey LawnSite Senior Member
    Posts: 332

    I too have used parts from Angelo's and I have been very pleased with both the prices and service.

    Plowing is everything (until spring)
  4. 75

    75 LawnSite Senior Member
    Posts: 992

    Glad you've got your unit back together again - was wondering where you were! Looking forward to seeing pics of your truck!
  5. Chuck Smith

    Chuck Smith LawnSite Senior Member
    Posts: 849

    Uncle Bob, I'd be glad to add those pics to my "Forum" section. Quite a few guys who post here have pics of their rigs in the Forum section of my website.


Share This Page