1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Rebuilt my Kohler somthings not right

Discussion in 'Mechanic and Repair' started by columbiaplower, Apr 29, 2008.

  1. columbiaplower

    columbiaplower LawnSite Senior Member
    Posts: 462

    i just rebuilt my kohler cv20s and i put it all back together tonight and when i start it up with the throttle at idle, the motor immediately start up at super high rpms, moving the throttle up and down does nothing? Im guessing this is a gov issue but im not sure. any help would be great.

    S DIAMOND LawnSite Member
    from South
    Posts: 108

    Start off with performing a static governor adjustment. It's on page 5.30 of your service manual.:walking:
  3. columbiaplower

    columbiaplower LawnSite Senior Member
    Posts: 462

    thanks ill give that a try
  4. Mike7468

    Mike7468 LawnSite Member
    Posts: 5

    Same issue with my CV23. Ready to just tear it down and rebuild it again.
  5. VegetiveSteam

    VegetiveSteam LawnSite Senior Member
    Posts: 297

    Did you take the gov gear off it's shaft and not replace it with a new one? Once you take them off their shaft they can't be reused. They have to be replaced. If you didn't touch the gov gear then yes do a static adjustment. To do that simply loosen the pinch bolt on the gov. lever where it clamps on to the gov. shaft. Move the gov. lever as far as it will go to open the throttle all the way. Then turn the gov shaft as far as it will go in the same direction and tighten the pinch bolt and you are done.

Share This Page