1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Redmax 7001 skip a problem?

Discussion in 'Mechanic and Repair' started by LCME, Apr 18, 2005.

  1. LCME

    LCME LawnSite Senior Member
    Posts: 430

    i just got out the redmax blower out of storage. started her up on the 2nd pull. let her warm up a few min. then went up to wot. ran smooth but started to skip a beat every 15 seconds. after running the blower through a few accounts the skipping stopped. what was that skip.
  2. spcfoor

    spcfoor LawnSite Senior Member
    Posts: 261

    It could have been some air or water in the fuel.
  3. vipermanz

    vipermanz LawnSite Bronze Member
    Posts: 1,773

    fuel filter, been through this scenario before, ni big deal
  4. grassmeister

    grassmeister LawnSite Member
    Posts: 73

    Mine is doing the same thing and it's only a few months old. I just spoke with the dealer who I bought mine from and he said it's a problem with the choke mechanism and the part has been recalled. He just got in a box with a bunch of replacement parts and said to just bring it in and he'd have the part replaced in about 15 minutes.
  5. grassmeister

    grassmeister LawnSite Member
    Posts: 73

    I must retract my previous post. My dealer thought I had an 8000, which is the model that has the problem. The 7001 doesn't have the same issue. So now I'm back to trying to figure this out. The dealer's mechanic said he has seen this with Champion spark plugs (what comes standard with it) and I should try switching to NGK or Bosch. Not sure how likely this will fix it, but it's easy enough to try. I'm just surprised this has happened so soon since it's only a few months old.

Share This Page