Redmax EBZ8000 backpack blower problem please help

Discussion in 'Mechanic and Repair' started by totallawncare912, Apr 19, 2006.

  1. totallawncare912

    totallawncare912 LawnSite Member
    Posts: 80

    My blower is about a year old and it is now acting up
    it starts great cold and runs awesomel but if i shut it off and go to reuse it a few minutes later it doesnt run right it is spitting and sputtering and wanting to die it sounds like to me anyone else had this issue and if so what needed to be done to fix it ?
     
  2. Mowingman

    Mowingman LawnSite Platinum Member
    from Texas
    Posts: 4,663

    Have your dealer tweak the metering valve in the carb. Than should fix it. We just fixed one today with the exact same symptoms
     
  3. dcondon

    dcondon LawnSite Silver Member
    Posts: 2,246

    check both of your lines that run into the gas tank. I will check tomorrow but one of them I pulled out and it run fine. I can't remember what color it was though.:hammerhead:
     
  4. totallawncare912

    totallawncare912 LawnSite Member
    Posts: 80

    i was reading another thread and some were saying it was a coil issue and i know on a lawn mower if the coil gets hot and its going out that it will be hard to start and if it does it will run funny
     
  5. totallawncare912

    totallawncare912 LawnSite Member
    Posts: 80

    like everyone on here is saying it runs great when its either cool or cold outside and when it hot it runs great the first go round but after that im SOL
     
  6. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,138

    So does this mean they take the carb apart and raise that meter valve? These machines really don't have a valve that can a customer can adjust with a screw driver correct? If he did what I think he did this unit won't run well at cold temperatures?
     
  7. traman

    traman LawnSite Senior Member
    Posts: 712

    when was the last time you put a new plug in ? that helps ,i have the same problem down here 80%humidity get a lot of vapor lock plus enclosed trailer doesn't help ,beside what was already said ,sometimes just crack open gas cap and push primer bulb to squirt in fresh gas ,usually clears it up
     
  8. totallawncare912

    totallawncare912 LawnSite Member
    Posts: 80

    never replaced the plug the blower doesnt have more then 5 or 10 hours on it totally the tank is still clear with the label still on it if that tells you anything ? still in very very nice condition
     
  9. work_it

    work_it LawnSite Senior Member
    Posts: 976

    A couple weeks ago my EB7001 started acting up like yours. I had the carb rebuilt last year because of the same problem, and just couldn't believe it when the darn thing started acting up again. I took the return line (clear) out of the top of the tank and put an old fuel filter on the end. This kept fuel from dripping down my back while aiding in evaporation. Then put a screw in the opening where the return line usually is. I haven't had any more problems....yet.
     
  10. totallawncare912

    totallawncare912 LawnSite Member
    Posts: 80

    why do you think that worked ? im just not understanding that they made the blower and it works great cold why would you or me or anyone have to jerryrig a 500.00 blower to get it to run when it was supposed to be the baddest MOFO on the planet ????
     

Share This Page