Redmax string trimmer

Discussion in 'Mechanic and Repair' started by MOOSE, Aug 5, 2004.

  1. MOOSE

    MOOSE LawnSite Senior Member
    Posts: 393

    Today my Redmax trimmer was running great. Then after lunch it decided not to run. Starts up and u give it gas and bogs and dies. Anybody have any clues. I tried loosening the gas cap to see if it was vent but still did it. Don't know...Help!
     
  2. Picman

    Picman LawnSite Member
    Posts: 20

    u check the air filter? sounds like 2 much gas, not enough air
     
  3. Moguy

    Moguy LawnSite Member
    Posts: 238

    "u check the air filter? sounds like 2 much gas, not enough air"
    Same thing happened to me earlier in July.
     
  4. General Grounds

    General Grounds LawnSite Senior Member
    Posts: 902

    :blob3: soundslike the gas cap isnt venting, if you have another sinilar trimmer (redmax), swop it and see if it helps if it does then you know wat you have to do. tony
     
  5. Bigg Bill

    Bigg Bill LawnSite Member
    Posts: 3

    Take off the muffler and check for carbon plugged screen.
     
  6. mcambrose

    mcambrose LawnSite Senior Member
    Posts: 511

    Yep, probably some carbon fell off and clogged the screen. It also will hardly idle if this is the case. I just take the screens off. If you want to keep it. Take the muffler off and spray it with brake cleaner to dissolve the carbon, then put it back of trimmer after it dries. My Shindiawa edger had this problem the other day. That was the first time in two years, so off with the screen. IT's screaming again.
     

Share This Page