Relays sealed?

Discussion in 'Hustler Turf Equip (Archived)' started by RonB, Aug 2, 2006.

  1. RonB

    RonB LawnSite Senior Member
    Posts: 429

    I have been having a hellva time with what seems to be relay problems. I had to go back to the dealer again today. The Super Z just shut down while cutting three times today.

    The other day we had a good rain and the mower got wet. The dealer checked the plug, no spark. He checked the relays again and when he went to unplug one the relays, the relay itself seperated and it was full of water.

    They replaced two of them with relays that are for boat use and those are truly sealed, but the ones on the mower are not. He got the mower going again (dealer has been great) and it ran for about 5 minutes so I brough it home. We'll see tomorrow if it's a fix.

    Why doesn't Hustler use SEALED relays? And if they are you're using a sorry brand because it looked nothing like the boat type sealed relays.

    btw - I'm still waiting on the flywheel/starter that has to be replaced from the screwed up relay last time. It's been almost 2 weeks.

    I'm not ready to holler the L word yet but it has entered my mind. Just going to the dealer has cost me over $100 in gas the last few weeks, not to mention about a days worth of work time.

    Mowers great when it runs but geezzz .. about 60 hrs and 5-6 trips to the shop.
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    We use the best relays available, Bosch.
    Is your dealer talking to anyone at the factory about this?
    E-mail me the details and your dealers info and I will get it looked into.

    Pj
     
  3. RonB

    RonB LawnSite Senior Member
    Posts: 429

    Pj,

    Bosch may be the best but why doesn't Hustler use sealed relays? It would seem being outdoor equipment that they would.

    The boat relay has epoxy or whatever sealing it completely. The dealer was going to call today and find out whats goin on, and he spoke with Ken I believe he said.

    I'll email the info tomorrow after I call and he hasn't found out anything.

    Thanks
    RonB
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    I am not sure that we don't, I will ask and see what they say.

    Pj
     
  5. RonB

    RonB LawnSite Senior Member
    Posts: 429

    Pj,

    The dealer says the parts should be here Monday.

    Here is a pic of the sealed relay they used on the left and the Hustler one on the right.

    Relays.jpg
     
  6. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    E-mail me your dealer information along with who you are working with there.

    Pj
     
  7. grassbandit

    grassbandit LawnSite Member
    Posts: 51

    I am feeling your pain. Had 3 relays go out in past 2 weeks, which by the way were not Bosch from the factory, but were replace with Bosch. Twice last week the wires on clutch connector plug melted, for some reason not yet determined. Last Monday my hydraulic oil filter built up so much pressure inside that it essentially exploded, oil everywhere, That was fun. Then by Saturday, my right Hydro pump locked up and sprayed oil
    everywhere. All of this at only 215 hrs. 27hp Kohler, xr7 66", brand new in April. I have lost about $1600 over this mower in the past two weeks. Luckily my dealer has been awesome, but this is making me consider what my next mower will be. The "L" word has definitely crossed my mind.
    Thanks for hearing my vent. I am not happy
     
  8. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    Grassbandit,
    E-mail me your info, I want to know whats going on with your mower ASAP.
     
  9. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    Would bad relay's cause my starter to try to engage while mowing? I think my flywheel may be damaged because of it.
     
  10. grassbandit

    grassbandit LawnSite Member
    Posts: 51

    Got mower back yesterday, Pump works great, but evidently ANOTHER relay just went out, because my fan is not coming on. Also, now my left handle feels a little sloppy. don't know what the problem could be yet, haven't used it enough yet.
     

Share This Page