1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

right blinker isn't working

Discussion in 'Trucks and Trailers' started by TimNNJ, Aug 5, 2009.

  1. TimNNJ

    TimNNJ LawnSite Senior Member
    Posts: 321

    what should I look for when checking it out..changed bulbs...wires...both trailers..no right blinker...when lights on they light up...just no blinker..what should I look for...
  2. mruiz

    mruiz LawnSite Member
    Posts: 205

    Do you have a two terminal bulb in it? Also to check the bulb you can take the left bulb and install it on the right side see if it works.
  3. grandview (2006)

    grandview (2006) LawnSite Gold Member
    Posts: 3,466

    What type of pug are you using? If it's a 7 prong plug ,one of the prongs could be broken.
  4. Isobel

    Isobel LawnSite Senior Member
    Posts: 548

    this probably won't help. but the other day when neither left nor right blinkers worked for me, I turned on the 4-way flashers--just to see if they worked--and they worked. After that my blinkers came back online. I have no idea why that was, but it worked.
  5. redmax fan

    redmax fan LawnSite Bronze Member
    Posts: 1,191

    the bulbs could be good but the fitting they plug into dirty / corroded and in need of cleaning . now at auto zone when i buy bulbs they say to buy a little tube of grease to apply into fitting to prevent corrosion / build up
  6. whitebp1

    whitebp1 LawnSite Member
    Posts: 76

    do they work on the truck? if not check fuses.. heck check them anyway some vehicles have seperate fuses for the trilaer lights
  7. pjtrailerguy

    pjtrailerguy LawnSite Member
    Posts: 29

    Definitely check your truck fuses. All newer trucks (1999 and newer) have seperate fuses for the trailer turn signals. They are labeled. Im pretty sure that will fix your problem. 9 times out of 10 thats what it is.
  8. TimNNJ

    TimNNJ LawnSite Senior Member
    Posts: 321

    Thank you I appreciate it!!really buggin me
    Posted via Mobile Device
  9. BladeRunner1967

    BladeRunner1967 LawnSite Member
    Posts: 202

    this happened to me at the beginning of Spring. It was the ground wire.
  10. topsites

    topsites LawnSite Fanatic
    Posts: 21,653

    I've learned to apply small dabs of die-electric grease to every contact on the plug that goes from trailer-truck.
    Use a paper clip to do it with, or a toothpick, just a small amount.

    Then the adapter I use also has lighted LED's that help me diagnose if current is coming through the truck to the plug...
    If the LED is lit that means the truck end is good and the problem's in the trailer, vice-versa if the LED does not light up
    it means my problem lies in the truck.
    Better still WHEN the LED lights up I know right away which WIRE is causing the problem (other than ground),
    all this helps me a LOT, it looks like one of these:

    Last edited: Aug 11, 2009

Share This Page