Scag mower problem

Discussion in 'Mechanic and Repair' started by chevytk, May 27, 2009.

  1. chevytk

    chevytk LawnSite Member
    Posts: 12

    When shutting my mower off,a kawasaki 19 hp,it takes one or two seconds before it will shut off. Anything I can do or any suggestions to help fix this problem?
     
  2. QualityLawnCare4u

    QualityLawnCare4u LawnSite Gold Member
    Posts: 3,758

    When you are turning it off, do you idle it down for about 30 seconds first? I do all my engines, kaw or kohler this way to prevent this. I will say that the kohlers are much worse about afterrun than the kaw. are. Also I have had bad gas cause this no matter what I did. I run a few ounces of sea foam once a month to help also. BTW, see you are not real far from me. Have not been to Byron in awhile.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    This is happening because there is a problem with the kill wire or possibly ignition switch.

    Check the harness plug connector at the engine for corrosion/rusted contacts, also check for any broken wires from the engine all the way to the ignition switch.

    It's running those couple seconds because you are killing power to the fuel cut-off solenoid to stop the engine.
     
  4. chevytk

    chevytk LawnSite Member
    Posts: 12

    >I always idle it down and let it run for at least 30 seconds, most the time longer. I also treat all my gas with sta-bil. I heard that,if you run sta bil in the gas that it's as good as any other product on the market. When running sea foam, do you run it strait in the gas, like stabil? I always run 93 oct. gas and buy it from a name brand store, like chevron, ect. no cheap gas, not saying I didn't get bad gas from these stations. Where you located, if I can ask? New to the thread, I might not need to ask these kind of questions. Let me know?


     
  5. chevytk

    chevytk LawnSite Member
    Posts: 12

    checked all my connections and everything checked out fine. I beleive I might of got water in the key hole so, I took my compsesser and blowed it out and today I cut some grass and it turned off like normal.
    Has anyone ever put graghite in the keyhole to make it function better?
     
  6. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    If it's working now you may be better off spraying electrical contact cleaner in it first working it in, Blow it out good then add a little graphite.
     
  7. chevytk

    chevytk LawnSite Member
    Posts: 12

    It's working like normal now. Thanks for the advise.
     

Share This Page