Sent Ferris a letter

Discussion in 'Lawn Mowing' started by thezaz, Oct 11, 2008.

  1. thezaz

    thezaz LawnSite Member
    Posts: 58

    So I sent Ferris A letter I had sent them a letter before on my 2000 and a few things i like to see different for what its worth. But today I sent them a letter about the new peace of gear that they still will not show us. They have you sign up for updates on the new gear and all you get is the same old thing and that's not anything at all. so there is that but has anybody had one side run slower? I go to do a turn and the left side responds fast but the right side respond slow and I have yet to fined out if it's something I can a just or have to take it in. I did a check to see if there is any hang ups and it's all good and greased so it makes me think it's a adjustment in the pump? i could use some help on this?
     
  2. mybowtie

    mybowtie LawnSite Senior Member
    from NY
    Posts: 683

    Mine did the same thing...new wheel motor fixed the issue.. had about 500 hrs on it at the time...........:usflag:
     
  3. ALC-GregH

    ALC-GregH LawnSite Fanatic
    from PA
    Posts: 7,053

    sounds like a wheel motor going bad.
     
  4. ericmcj31

    ericmcj31 LawnSite Senior Member
    Posts: 404


    No offense or anything, but I hope you used better grammar when you wrote to Ferris. :confused:
     
  5. thezaz

    thezaz LawnSite Member
    Posts: 58

    yes i did use better grammar
     
  6. PTSolutions

    PTSolutions LawnSite Silver Member
    from OH
    Posts: 2,328

    my left side does the same on my mower, check out my post: ? on ferris...

    it ended up being a sheared key, twice!
     
  7. gravedigger5

    gravedigger5 LawnSite Senior Member
    Posts: 505

    On my 3100 series the left side started slowing down but only on big hills or where it was under a decent load. Thought it was wheel motor and replaced that, still doing same thing ended up one of two v belts missing that run the hydro system. The right side the belts would make a really tight wrap almost all the way around the pulley but on the right side about a half a wrap around pump pulley because of the idler arm pulley location. Put a new set (2) of belts on and runs great.
     

Share This Page