SP Sprayer Leaking

Discussion in 'Pesticide & Herbicide Application' started by Eclipse, Aug 14, 2005.

  1. Eclipse

    Eclipse LawnSite Bronze Member
    Posts: 1,149

    I have two SP Sprayers, one is a couple years old and the other is less than a week old, and both are leaking in the same spot. Out of the bottom where the plunger is. Any ideas exactly what would need replacement. Is it common for them to develop a leak in this area?

    I purchased another SP Sprayer because they are highly regarded on this site, but personally I have had much better luck with my Solo. Hopefully it is a quick and simple fix, bad o-ring or something.

    Thanks.
     
  2. ArizPestWeed

    ArizPestWeed LawnSite Bronze Member
    Posts: 1,457

    If it's piston type , junk it
    Diaphram type , well , still junk the old and take the new one back to where you bouhgt it
     
  3. Eclipse

    Eclipse LawnSite Bronze Member
    Posts: 1,149

    Sorry, I forgot to include the models.

    The older one is an SP2, so it is a piston, and the newer one is an SPO.

    Thanks for the reply.
     
  4. teeca

    teeca LawnSite Bronze Member
    Posts: 1,202

    let us know what you find out, i am thinking of ordering 3 sp0's, they claim to have the least amount of leaks, i have had the solo's and they last a long time, but leak!!
     
  5. ArizPestWeed

    ArizPestWeed LawnSite Bronze Member
    Posts: 1,457

    I've got 10 SP 3 and no leaks .
    Had 4 Solo but the lid leaked , sent them back and solo sent me 4 more that I sold to a shop .
    So for , SP is working
     
  6. ToniDavies

    ToniDavies LawnSite Member
    Posts: 137

    Ihave never seen the SPO leak that quickly. It is the best unit SP makes. Call the company you purchased it from maybe there is a recall.
     
  7. Eclipse

    Eclipse LawnSite Bronze Member
    Posts: 1,149

    They are going to give me a new one tomorrow when I stop in. Hopefully it holds up much better than the first one.

    Amazing how we all have different luck with different products. My Solo has been great, SP not so great :)

    I will say that the Solo wands are crap IMHO as compared to the SP.

    Thanks again.
     
  8. jajwrigh

    jajwrigh LawnSite Bronze Member
    Male, from Martinsville, IN
    Posts: 1,405

    Did you tighten the hose clamp at the base of the sprayer when you bought it? Remember they come loose from the factory. I have had no problems with mine what so ever....let us know what you find.
     
  9. Eclipse

    Eclipse LawnSite Bronze Member
    Posts: 1,149

    Thanks for the suggestion. I did tighten the hose clamps. They are leak free.
     
  10. ArizPestWeed

    ArizPestWeed LawnSite Bronze Member
    Posts: 1,457

    Eclipse
    I bought 10 solo wands conplete from hose to tip ans use 'em on my SP.
    I like solo wands better
     

Share This Page