spark issue kohler cv22s 22hp twin

Discussion in 'Mechanic and Repair' started by subs1000w, May 31, 2009.

  1. subs1000w

    subs1000w LawnSite Member
    Posts: 160

    started the engine up in the morning and engaged the blades, no power almost killed the engine so its only running on one cylinder so then i began diagnosing the problem 1st i replaced the plugs because they were old but no fix then i replaced both the coils because they both tested alittle outa spec and were original so i figured id be a good idea but still nothing so i searched on here and found it could be the spark advance module so i replaced that thinking it had to be it but still same problem then i tested the new coils which test fine the old ones are out of spec but are close and do work so ive swaped and switched just about every parts combination between 4 coils and 2 sams and 3 sets of plugs and nothing im stumped ive also unplugged the kill wire and test 12v going to the SAM, the crazy thing is when i pull both plugs and turn the engine over they both fire although it maybe looks alittle weak but i dont know what it looked like before but i put them back in and its like there outa time so it only runns on one it will run on either side but not both at the same time i would unplug the sam wires from one and start it one and then plug the other back in and the sound would change alittle but then i would unplug just one and it dies, im stumped any help would be great maybe how to test the sam i cant find out how to do that
     
  2. grandview (2006)

    grandview (2006) LawnSite Gold Member
    Posts: 3,466

    Pull the cover and see if the rods are out of adjustment.
     

Share This Page