Speedometer issue

Discussion in 'Mechanic and Repair' started by LawnTamer, Aug 24, 2007.

  1. LawnTamer

    LawnTamer LawnSite Gold Member
    Posts: 3,988

    Howdy all,
    I have a 2004 2500HD that started doing something weird yesterday, and repeated it today.
    The speedometer doesn't work when the truck is cold. Once the truck is warmed up it starts edging up a bit and after a few minutes it works just fine for the rest of the day.
    Anyone had this happen?
    Any ideas?
     
  2. jpp

    jpp LawnSite Silver Member
    Posts: 2,128

    Does it get stuck in one postion? Mine went up to 100 mph when I had the plow on. 04 2500. Going down the freeway I had to look at the wall to make sure I was not going that fast. Long story short, call the dealer and tell them. It is the instrument cluster panel will need replaced. I may have a bulletin for it but it will take some searching on my end.

    JP
     
  3. Tturfcare

    Tturfcare LawnSite Member
    Posts: 28

    do you have oversized tires on the truck?
     
  4. Dirt Digger2

    Dirt Digger2 LawnSite Silver Member
    from PA
    Posts: 2,396

    might be the speed sensor in your rear diff?...we had similiar problems in our F350 and that fixed it.
     
  5. LawnTamer

    LawnTamer LawnSite Gold Member
    Posts: 3,988

    Nah, it's the instrument cluster. Really upsets me that Chevy put an underbuilt circuit board in the panel, so instead of trying to do right by their customers, they sell a replacement for $475!:confused:
     
  6. richard1103

    richard1103 LawnSite Member
    Posts: 120

    clusters should have been recalled mine went out at 19k in 05 chevy
     
  7. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,833

    You better off with ford:drinkup:
     
  8. LawnTamer

    LawnTamer LawnSite Gold Member
    Posts: 3,988

    They did do a recall:clapping::clapping:

    I got it fixed for free a few weeks ago.
     

Share This Page