1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Sthil FS 75 trimmer only runs a little while

Discussion in 'Mechanic and Repair' started by mowingismylife, May 13, 2004.

  1. mowingismylife

    mowingismylife LawnSite Member
    Posts: 48

    My dad has a Sthil FS 75 and we used it this year on are own lawn and it ran good for the first 2 times and then the problem we had last year came back. Last year you could run it for about 20 mins and it would stop and not start until it was cool. This year it ran good the first 2 times using it and we used it about almost a hour and then it finally stopped and wouldn't start. Now when you go to start it it will start and run for about 10 mins tops and then die we cleaned the tank changed the gas,cleaned the carb and so on. We think it is a gas problem. The gas line in the tank should have a filter on it right? should this filter float or should it lay at the bottom of the gas tank? What other things could make the trimmer run for a limited time and then just cut out and not start? thanks for any input
  2. mudpie

    mudpie LawnSite Member
    Posts: 45

    yes it should have filter in gas tank all the ones i have seen are wieghted so the stay on the bottom of the tank on matter what angle you hold them.fuel filter dirty, gas thank vent stooped, gas line very soft? it will colapse when hot and shut off fuel crankshaft seal going bad- you have to vacume check this, spark plug,
  3. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,100

    The next time it stops check the plug right a way to be sure it is firing. I have seen coils get hot and stop firing but as soon as they cool enough they would be ok until they got hot again.
  4. LynyrdSkynyrd

    LynyrdSkynyrd LawnSite Member
    Posts: 179

    Have you cleaned the exhaust screen yet?
    If not remove it and give it a good cleaning.
  5. gene gls

    gene gls LawnSite Gold Member
    Posts: 3,213

    I have a FS 74 with a simular problem. It will run fine for about an hour and then it will not rev up when you squeeze the triger.

  6. mowingismylife

    mowingismylife LawnSite Member
    Posts: 48

    yup cleaned the exaust screen haven't cleaned the full exaust yet but did that last year and that seemed to help. On the trimmer it does have a fule filter on it but it floats and does not stay at the bottom so its supposed to be stuck at the bottom at all times right? Hey Gene this trimmer has done that same thing too it would start up fine and not have any power really at all and you couldn't rev it up we fixed that some how last year i think but this year its just running for a short time and dying on us. So it could for sure be a spark plug thing too? I have no clue when it was last changed since this trimmer has been used mainly on the big home yard. But i will try this advice and see if we can get it running again. I know the local service guy for us said that it could be something i am not sure what it was called but i know he said it has a lifetime warranty on this one part and i forget what it now tho ;)
  7. HayBay

    HayBay LawnSite Senior Member
    from Ontario
    Posts: 846

    I have the Sthil Fs66 (older model)

    I was just about ready to give up on this trimmer and aquire a replacement. I then took another look at it and found my High Speed Adjustment on the carburator would vibrate out of position. I rapped a thin piece of wire into the High Speed Adjustment spring so it wouldn't vibrate out of place, now things are perfect.

    My symptoms were similar

Share This Page