Stihl backpack 550, hose keeps coming off

Discussion in 'Lawn Mowing' started by brandonppr, Apr 10, 2013.

  1. brandonppr

    brandonppr LawnSite Member
    from tn
    Posts: 57

    I just bought a brand new blower and from the first time we used it, the hose has fallen off. I have to keep stopping and tightening the clamp up.

    Has anyone else had this problem?
     
  2. orangemower

    orangemower LawnSite Silver Member
    from pa
    Posts: 2,773

    1 or 100. Doesn't matter. Take it back to the dealer and have them fix or replace it instead of waiting for a answer that may never come.
     
  3. Colaguy

    Colaguy LawnSite Senior Member
    Posts: 599

    I had this prob on my BR 600 (3) yrs ago after buying it. My solution was to use duct tape wrapped around several times. Solved the problem though it was strange that it kept coming off.
     
  4. brandonppr

    brandonppr LawnSite Member
    from tn
    Posts: 57

    I am going to take it to the dealer, but I was wondering if this was just me that had this problem or if this happens often.
     
  5. JTLarson

    JTLarson LawnSite Member
    Posts: 248

    My BR600 was doing the same thing. I took the clamp off and turned it around and it hasn't come apart since. I couldn't see why it made a difference, but it did. May be in dealer setup.
     
  6. Ridin' Green

    Ridin' Green LawnSite Fanatic
    Male, from Michigan
    Posts: 13,748

    Hey JT, welcome back! Good to see you posting again.:)
     
  7. JTLarson

    JTLarson LawnSite Member
    Posts: 248

    Thanks! Been watching the site but haven't said much. I bought a Ferris 3100Z last year and ran it. Been wanting to type up a review, but just haven't got around to it yet. I will get to it one of these days. I enjoy reading your posts too.
     
  8. Ridin' Green

    Ridin' Green LawnSite Fanatic
    Male, from Michigan
    Posts: 13,748

    You should post some of your thoughts in the thread here about the Ferris mowers. Lots of debate going on in that one. I think it is in the mowing equipment sub forum.:)
     
  9. psdnate

    psdnate LawnSite Member
    Posts: 123

    I have the same problem with my 500. It's so annoying! I haven't talked to my dealer about it yet.
     
  10. TFLE

    TFLE LawnSite Senior Member
    Posts: 289

    You could try to put a real hose clamp on it, one that tightens down tighter than the black plastic one. Hell spray it black before you put it on and you'll never notice.
     

Share This Page