stihl br 400 leaf blower

Discussion in 'Mechanic and Repair' started by gaas12, May 26, 2005.

  1. gaas12

    gaas12 LawnSite Member
    Posts: 1

    :waving: i am working on my br 400 leaf blower, but i have a problem. it will set and run at idle speed, but when i try to give some gas by the throttle it bogs down and goes dead, if i don't let off on the throttle it will set and idle. any ideas? thanks.
     
  2. partstree

    partstree Sponsor
    Posts: 79

    could you clarify on what you mean, that doesn't make much sense to me, "if i don't let off on the throttle it will set and idle." how are you letting off the throttle if it dies when you open?
     
  3. Lawn Masters

    Lawn Masters LawnSite Senior Member
    Posts: 850

    Take the spark arrestor screen out of the muffler, that should make a BIG difference in its performance.
     
  4. topsites

    topsites LawnSite Fanatic
    Posts: 21,654

    Check and replace the air filter and make sure the choke is OFF after you get it running :)
     
  5. joe stihl

    joe stihl LawnSite Member
    Posts: 35

    You aren't getting enough fuel. Could be because of several things.

    High speed jet needs to be opened a little. Try setting both high and low speed jets at 1 round - gently turn screw in until it sets and then open it one turn. This is a good starting point. Adjust jets from there. If it has limiter caps then open both all the way ( should be no more than 3/4 turn).

    or

    Carb needs rebuilding.

    or

    Fuel line cracked.

    or

    Fuel filter clogged.
     

Share This Page