Stihl BR 400 problems

Discussion in 'Lawn Mowing' started by Phishook, Apr 26, 2002.

  1. Phishook

    Phishook LawnSite Bronze Member
    Posts: 1,143

    One of my blowers (stihl BR 400) is dying when it gets hot. It sounds like it's being choked. As soon as you let off the gas, it idles fine. Replaced the plug, and new gas before I started this spring.

    We ran 32:1 mix in it for awhile last fall.

  2. Holloway Lawns

    Holloway Lawns LawnSite Senior Member
    Posts: 253

    I have the same blower and have had no problems. Just had it tuned up at the dealer. You may want to take it in for them to check it out. Good luck.
  3. Premo Services

    Premo Services LawnSite Bronze Member
    Posts: 1,516

    I have a 400 and a 320. I had the same problems with my br320 and it was a clogged exaust port and spark arrestor screen. The stihl mix I believe is 50/1. Clean them and it should run fine. I switched to amsoil synthetic 2 cycle oil last year and have not had any clogged ports or have not even changed the spark plug. Both of them run great.
  4. Phishook

    Phishook LawnSite Bronze Member
    Posts: 1,143

    thankx premo. I'll try that first thing in the morning.
  5. jeffex

    jeffex LawnSite Bronze Member
    Posts: 1,933

    loosten the gas cap and if you hear a sucking soud the tank may be building up pressure. replace gas cap or check for clogged breather. They will sound like they are running out of gas.
  6. tim cooper

    tim cooper LawnSite Member
    Posts: 71

    same thing happened to mine... took it in to shop ... guy looked at it took off the spark arrestor screen on the exhaust....cranked up runnin fine now.......all because of those darn democrats out in california....california emmisons... go figure.......
  7. Barkleymut

    Barkleymut LawnSite Bronze Member
    Posts: 1,117

    I think it is the gas cap also. I have the same blower as you and have had the same problem. Get a new gas cap.

Share This Page