Stihl Weedeater problem

Discussion in 'Lawn Mowing' started by D&V, Apr 8, 2001.

  1. D&V

    D&V LawnSite Member
    Posts: 24

    I have a Stihl FS80 weedeater that is not even a year old. When I was running it yesterday it started blowing out white smoke and didnt run strong like it should. It sounds like a bogging sound inside, and dosnt run nearly like it should. I was wandering if anyone has had this problem before, or if anyone has any suggestions of what is wrong with it.
     
  2. E-man

    E-man LawnSite Member
    from PA
    Posts: 136

    try checking the spark arrester screen if its all gunked up either clean it or replace it. I'm constantly cleaning these screens on my stihls
     
  3. Southern Lawns

    Southern Lawns LawnSite Senior Member
    Posts: 259

    You clean them? Mine wouldn't even run with it on there. I pulled them off all the tools. They run great now.
    Dealer advise was "get rid of em"
     
  4. 65hoss

    65hoss LawnSite Fanatic
    Posts: 6,360

    I'm having the same problem with mine lately. I plan to drop it off at the shop in the morning. I took the fuel filter off thinking that was the problem but I was wrong. The carb must need to be clean or something.
     
  5. skyphoto

    skyphoto LawnSite Member
    Posts: 221

    If it is not the spark screen then take it and have the carb checked....They did mine and while talking to the mechanic he said the carbs on the 2cycle are tuned so precise due to the emissons policy that they are prone to pieces of dirt and debris plugging them that the smallest particle can cause a huge loss of performance....

    Peace!
    Oh I have the fs85 btw
     
  6. D&V

    D&V LawnSite Member
    Posts: 24

    Thanks for the help. I took the screen out and it ran just like it should. Im glad thats all that was wrong with it.
     

Share This Page