Stilh Edger Won't Run For More Than 5 Seconds

Discussion in 'Mechanic and Repair' started by Tuna3679, Dec 27, 2008.

  1. Tuna3679

    Tuna3679 LawnSite Member
    Posts: 96

    I just replaced my carburetor in my stihl edger and now it will only run for a few seconds before dying does anyone know what is causing this? Any help will be much appreciated.
  2. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    1st guess since you are saying this is a new carb...............You have your fuel lines hooked up wrong, meaning you have the return(non filtered) line hooked to the inlet or suction side of the carb and the main line(filtered)hooked to the return side of the carb.

    And almost forgot............Welcome to LawnSite!!!!!!!!!!!!!
  3. AmsoilPower

    AmsoilPower LawnSite Senior Member
    Posts: 938

    Or the fuel line is broken off inside the tank. Welcome to the site.
  4. Phil G

    Phil G LawnSite Senior Member
    Posts: 843

    While you're there, check the filter on the end of the pipe in the tank, might be blocked.

    Also, when you fitted the carb did you pull the fuel pipe out? Check it's not kinked between the carb and the tank.

    Good luck, Phil
  5. Tuna3679

    Tuna3679 LawnSite Member
    Posts: 96

    I checked the fuel lines they are connected properly and not kinked. Edger will start, then run only when fully choked and at full throttle, when i let off the throttle it dies instead of idles...Any more suggestions before I take to have it repaired. Thanks for all the help guys. :)
  6. Phil G

    Phil G LawnSite Senior Member
    Posts: 843

    Could I ask why you replaced the carb?

    Does the new carb have two mixture screws? Make sure they are not turned in all the way. Set them both one and a half turns out from closed. This should get the unit running.

    Have you had the exhaust off to check the condition of the piston?

    Good luck, Phil :ukflag:

  7. Tuna3679

    Tuna3679 LawnSite Member
    Posts: 96

    I replaced the carbs in all my stilh they are all four years old, 3 line trimmers and 2 edgers and this is the only one that is giving me a problem after fiddling with adjustment screws I finally got it to run and idle but it will only run when it is fully choked when i choke it down it dies even at full throttle
  8. Tuna3679

    Tuna3679 LawnSite Member
    Posts: 96

    Oh and checked the piston from carb side it looks great and edger ran fine before i screwed it up :)
  9. Grassmechanic

    Grassmechanic LawnSite Silver Member
    Posts: 2,697

    Did you check the screen in the muffler?
  10. ricky86

    ricky86 LawnSite Bronze Member
    Posts: 1,842

    Make sure you didn't switch the mount gasket with the air filter gasket. The mount has a hole for the impulse. Then remove the muffler and inspect cylinder.

Share This Page