Super Z EFI dead

Discussion in 'Hustler Turf Equip (Archived)' started by SugarValley, Aug 20, 2013.

  1. SugarValley

    SugarValley LawnSite Member
    Posts: 1

    I have a 2005 Hustler Super Z 72" with the 28hp EFI Kohler. 2 weeks ago, I turned the engine off for a brief moment while talking to someone. When I went to start it, I received a loud click then nothing. Fans are not running with the key on, PTO clutch is not engaging, engine lights on the panel are not lighting up....completely dead. Checked all fuses (3 on the panel and 2 behind the seat), nothing is blown. I have power to the ignition switch so i assumed it was possibly the switch. Replaced switch today after work and still no go. Battery is good. It was replaced at the beginning of this year and hasn't given me issues. What am I missing? What would cause everything to completely die at once?
  2. hustlermidwest

    hustlermidwest LawnSite Senior Member
    Posts: 636

    Interlock could be the issue. Is there juice on the large cable battery side of the starter solenoid?

    Brian O
  3. jhsmith4

    jhsmith4 LawnSite Member
    from Ga
    Posts: 110

    I experienced the same problem on our 08 28EFI, took battery out had it check and charged. Ran good for about 45mins, Battery went completely dead. Took the battery had it check and charged again, replaced, found one wire terminal off of voltage regulator, reconnected, been running great since.
  4. hustlermidwest

    hustlermidwest LawnSite Senior Member
    Posts: 636

    Be mindful of that wire. I believe it's purple but don't hold me to that. It's your charging wire. Sometimes with those kohlers and Kawasaki's for that matter that wire gets loose and you lose your amperage. Make sure it's a clean solid contact.

    Brian O

Share This Page