Super Z Mower Deck Won't Engage

Discussion in 'Hustler Turf Equip (Archived)' started by sbailey183, May 1, 2012.

  1. sbailey183

    sbailey183 LawnSite Member
    Posts: 3

    I was mowing and stopped to pick up an item, disengaging the mower. I returned to the mower immediately and when I pulled the switch all I got was a click. I've had the unit for a few years and had this happen once before but I can't remember how I fixed the problem? Do I need a new switch or am I missing something else?
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    If your hearing a click I am guessing the clutch is engaging, I would check your belt for tension or to see if it broke or fell off? and if so why.

    Pj
     
  3. sbailey183

    sbailey183 LawnSite Member
    Posts: 3

    It was the belt. Probably broke because I engaged the deck at high RPM's. My bad. I also found that the bold holding my tension arm was gone. Probably didn't help belt.

    My model number is 926980 and I picked up a belt, part number 781310 but it's too long, even after using the tension adjustment. It shows on the part in the catalogue that it's 180". I measured the old one and that was 178" and I'm guessing that it could be stretched. The belt seems to be about 4" too long.

    I'm the guy who didn't figure out on my own the belt was broke so I'm assuming I'm doing something wrong even though I've successfully installed belts on the unit before. Am I not adjusting the belt correctly or was I given the wrong one?
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    That is the correct part # belt for your deck.
    I replied to your emails this am and sent you the manual with the belt diagram in it.

    Pj
     

Share This Page